Install the Google plugins for Eclipse

From LogicalDOC Community Wiki
Jump to: navigation, search

The graphical interface of LogicalDOC is based on technology Google GWT (Google Web Toolkit).

So we must install the Eclipse plugin from Google, including the GWT compiler, which deals with the construction of the components that make up the Web interface.

Detailed instructions are available on the Google site at the following addresses:
https://developers.google.com/eclipse/docs/download

Specific instructions for Eclipse 4.4 (Luna)
https://developers.google.com/eclipse/docs/install-eclipse-4.4

  1. Select from the Help menu item Install New Software...
  2. Add the Google repository (in this case I add that for Eclipse Luna 4.4)
  3. Select the packages to install
  4. The packages shown will be downloaded and installed
  5. Installation Procedure
  6. Confirm installation of unsigned packages
  7. The system requires restarting Eclipse
  8. In the preferences we can see now that the package Google Web Toolkit has been installed